Problem with Mojave?

2D CAD software for Windows, Mac OS X and Linux
Mikerosen
Posts: 279
Joined: Sun Dec 11, 2011 6:16 pm
Location: Seattle, WA, USA
Contact:

Problem with Mojave?

Post by Mikerosen » Mon Oct 15, 2018 4:29 pm

Eric,
I recently upgraded to a new iMac, and the Mojave OS. When I quit RC, I get a message that RC quit unexpectedly. Is this a problem with Mojave? Should I send you the error report?

Thanks!
Attachments
Screen Shot 2018-10-15 at 9.27.33 AM.png
Screen Shot 2018-10-15 at 9.27.33 AM.png (94.72 KiB) Viewed 324 times
Mike Rosen
Seattle, WA, USA

Mac OS 10.14, iOS 11.4.1 on iPad Pro

Eric Pousse
Posts: 667
Joined: Sat Dec 03, 2011 12:31 pm
Location: Tours - France

Re: Problem with Mojave?

Post by Eric Pousse » Tue Oct 16, 2018 1:18 pm

Bonjour Mike,

I don't have switched to Mojave.
If you can send me the error report, perhaps I can see what is bad, thanks.

Cordialement.
Eric Pousse

Eric Pousse
Posts: 667
Joined: Sat Dec 03, 2011 12:31 pm
Location: Tours - France

Re: Problem with Mojave?

Post by Eric Pousse » Tue Oct 16, 2018 1:21 pm

Mike,

Which version of RealCADD do you use?
If it is not 4.90 beta, can you test it, please?

Thanks.
Eric Pousse

Mikerosen
Posts: 279
Joined: Sun Dec 11, 2011 6:16 pm
Location: Seattle, WA, USA
Contact:

Re: Problem with Mojave?

Post by Mikerosen » Tue Oct 16, 2018 2:52 pm

I'm on 4.8. Can you send me a link to the 4.9 beta, please?

I copied the Error Report as a PDF, but I can't attach it.
Mike Rosen
Seattle, WA, USA

Mac OS 10.14, iOS 11.4.1 on iPad Pro

Eric Pousse
Posts: 667
Joined: Sat Dec 03, 2011 12:31 pm
Location: Tours - France

Re: Problem with Mojave?

Post by Eric Pousse » Tue Oct 16, 2018 5:30 pm

Eric Pousse

Mikerosen
Posts: 279
Joined: Sun Dec 11, 2011 6:16 pm
Location: Seattle, WA, USA
Contact:

Re: Problem with Mojave?

Post by Mikerosen » Tue Oct 16, 2018 7:45 pm

Merci. I'll try it out, and let you know.
Mike Rosen
Seattle, WA, USA

Mac OS 10.14, iOS 11.4.1 on iPad Pro

Mikerosen
Posts: 279
Joined: Sun Dec 11, 2011 6:16 pm
Location: Seattle, WA, USA
Contact:

Re: Problem with Mojave?

Post by Mikerosen » Tue Oct 16, 2018 10:04 pm

Seems to be fine. Merci!
Mike Rosen
Seattle, WA, USA

Mac OS 10.14, iOS 11.4.1 on iPad Pro

debenriver
Posts: 461
Joined: Sat Dec 03, 2011 9:19 pm
Location: Maine USA and Suffolk England
Contact:

Re: Problem with Mojave?

Post by debenriver » Wed Oct 17, 2018 12:36 pm

I get this quite regularly when I quit RealCADD – I'm running 4.90b9 on 10.13.6. Not every time I quit. but most every time! So it predates Mojave.

Cheers -- George

Mikerosen
Posts: 279
Joined: Sun Dec 11, 2011 6:16 pm
Location: Seattle, WA, USA
Contact:

Re: Problem with Mojave?

Post by Mikerosen » Wed Oct 17, 2018 2:33 pm

That's interesting. I had no trouble until the update.

I'll keep an eye on it, and report back if it continues.
Mike Rosen
Seattle, WA, USA

Mac OS 10.14, iOS 11.4.1 on iPad Pro

Eric Pousse
Posts: 667
Joined: Sat Dec 03, 2011 12:31 pm
Location: Tours - France

Re: Problem with Mojave?

Post by Eric Pousse » Wed Oct 17, 2018 3:48 pm

Mike, George,

I can't reproduce this problem with 10.13.6 but I have installed Mojave with Parallels Desktop and I can reproduce it when there is more than one drawing opened when I quit RealCADD.
I think that RealCADD 4.90b10 solves this problem.
Mike, can you confirm that with 2 or more drawings opened you have this bug with 4.90b9? and not with 4.90b10?
George, can you say if you have also this problem with 4.90b10 and 10.13.6?
George, I think that you have a special Mac to find bugs in RealCADD ;)

Mike, I see some cosmetic bugs with Mojave in Parallels Desktop around pallets, like this :
Image
Do you see this also or is it Parallels Desktop?

Thanks.
Cordialement.
Eric Pousse

Post Reply